IP Mobile Router Configurations and Show Command Output

icon IP Mobile Router - Configs and Show Command Output

Introduction

The network built used the addressing shown in the following figure:


Configurations

Show Command Output


Configurations

HomeAgent Config

HomeAgent#sh run
Building configuration...

Current configuration : 1110 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname HomeAgent
!
enable password san-fran
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0
ip address 172.16.100.1 255.255.255.0
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
ip address 192.30.1.1 255.255.255.0
no ip mroute-cache
no fair-queue
clockrate 4000000
!
interface Serial1
no ip address
shutdown
!
router mobile
!
router eigrp 1
redistribute mobile metric 10 2000 255 1 1500
network 1.0.0.0
network 172.16.0.0
network 192.30.1.0
auto-summary
no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip pim bidir-enable
ip mobile home-agent
ip mobile virtual-network 172.16.2.0 255.255.255.0
ip mobile host 172.16.2.1 virtual-network 172.16.2.0 255.255.255.0
ip mobile mobile-networks 172.16.2.1
network 148.33.0.0 255.255.0.0
ip mobile secure host 172.16.2.1 spi 100 key ascii cisco
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
password cisco
login
!
end


Foreign Agent Config

ForeignAgent#sh run
Building configuration...

Current configuration : 1084 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ForeignAgent
!
enable password san-fran
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0
ip address 192.30.2.1 255.255.255.0
ip irdp
ip irdp maxadvertinterval 10
ip irdp minadvertinterval 7
ip irdp holdtime 30
ip mobile foreign-service
!
interface Ethernet1
ip address 192.30.3.1 255.255.255.0
ip irdp
ip irdp maxadvertinterval 10
ip irdp minadvertinterval 7
ip irdp holdtime 30
ip mobile foreign-service
!
interface Serial0
ip address 192.30.1.2 255.255.255.0
no ip mroute-cache
no fair-queue
!
interface Serial1
no ip address
shutdown
!
router mobile
!
router eigrp 1
network 2.0.0.0
network 192.30.1.0
network 192.30.2.0
network 192.30.3.0
auto-summary
no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip pim bidir-enable
ip mobile foreign-agent care-of Serial0
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
password cisco
login
!
end


MobileRtr Config

MobileRtr#sh run
Building configuration...

Current configuration : 996 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname MobileRtr
!
enable password san-fran
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Ethernet0
ip address 148.33.2.129 255.255.255.192
no ip route-cache
no ip mroute-cache
!
interface Ethernet1
ip address 172.16.2.1 255.255.255.252
ip mobile router-service roam
ip mobile router-service solicit
no ip route-cache
no ip mroute-cache
!
interface Serial0
no ip address
no ip route-cache
no ip mroute-cache
shutdown
!
interface Serial1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
!
router mobile
!
ip classless
no ip http server
ip pim bidir-enable
ip mobile secure home-agent 1.1.1.1 spi 100 key ascii cisco
ip mobile router
address 172.16.2.1 255.255.255.0
home-agent 1.1.1.1
!
!
!
line con 0
exec-timeout 0 0
line aux 0
transport input all
line vty 0 4
password cisco
login
!
end


Show Command Output

MobileRtr Show Commands

MobileRtr#sh ip mob rou

Mobile Router
Enabled 03/01/93 00:01:14
Last redundancy state transition NEVER

Configuration:
Home Address 172.16.2.1 Mask 255.255.255.0
Home Agent 1.1.1.1 Priority 100 (best)
Registration lifetime 65534 sec
Retransmit Init 1000, Max 5000 msec, Limit 3
Extend Expire 120, Retry 3, Interval 10

Monitor:
Status -Registered-
Active foreign agent 192.30.2.1, Care-of 192.30.1.2
On interface Ethernet1
Tunnel0

This is where I shifted the Ethernet link from Ethernet1 to Ethernet0:

MobileRtr#
00:02:27: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed sta
te to down
00:02:37: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed sta
te to up

MobileRtr#sh ip mob rou

Mobile Router
Enabled 03/01/93 00:01:14
Last redundancy state transition NEVER

Configuration:
Home Address 172.16.2.1 Mask 255.255.255.0
Home Agent 1.1.1.1 Priority 100 (best)
Registration lifetime 65534 sec
Retransmit Init 1000, Max 5000 msec, Limit 3
Extend Expire 120, Retry 3, Interval 10

Monitor:
Status -Registered-
Active foreign agent 192.30.3.1, Care-of 192.30.1.2
On interface Ethernet1
Tunnel0

MobileRtr#sh int tu 0
Tunnel0 is up, line protocol is up
Hardware is Tunnel
Interface is unnumbered. Using address of Ethernet1 (172.16.2.1)
MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive set (10 sec)
Tunnel source 172.16.2.1, destination 1.1.1.1
Tunnel protocol/transport IP/IP, key disabled, sequencing disabled
Checksumming of packets disabled, fast tunneling enabled
Path MTU Discovery, ager 10 mins, MTU 0, expires never
Last input 00:01:30, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out

MobileRtr#sho ip mob ?
aaareq IP Mobility mobile author request sent to AAA
binding Mobile IP bindings
globals Mobile IP mobile global info
host Mobile IP mobile hosts info
interface Mobile IP mobile interface info
mobile-network Mobile networks
router Mobile Router information
secure Mobile IP security associations
traffic Mobile IP protocol statistics
tunnel Mobile IP tunnels
violation Mobile IP security violation log
visitor Mobile IP visitors

MobileRtr#sho ip mob int
IP Mobility interface information:

MobileRtr#sho ip mob tun
Mobile Tunnels:

Tunnel0:
src 172.16.2.1, dest 1.1.1.1
encap IP/IP, mode reverse-allowed, tunnel-users 1
IP MTU 1480 bytes
Path MTU Discovery, mtu: 0, ager: 10 mins, expires: never
outbound interface Ethernet1
MR created, fast switching enabled, ICMP unreachable enabled
3 packets input, 168 bytes, 0 drops
0 packets output, 0 bytes

MobileRtr#sh ip rou
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter are
a
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 192.30.3.1 to network 0.0.0.0

    172.16.0.0/30 is subnetted, 1 subnets
C      172.16.2.0 is directly connected, Ethernet1
    148.33.0.0/26 is subnetted, 1 subnets
C      148.33.2.128 is directly connected, Ethernet0
    192.30.3.0/32 is subnetted, 1 subnets
M      192.30.3.1 [3/1] via 192.30.3.1, 00:00:54, Ethernet1
M*  0.0.0.0/0 [3/1] via 192.30.3.1, 00:00:54, Ethernet1

Note that a default route was added, also the address of the currently active interface on the Foreign Agent.

MobileRtr#sh ip mob traff
IP Mobility traffic:
Advertisements:
Solicitations received 0
Advertisements sent 0, response to solicitation 0
Home Agent Registrations:
Register 0, Deregister 0 requests
Register 0, Deregister 0 replied
Accepted 0, No simultaneous bindings 0
Denied 0, Ignored 0 , Dropped 0
Unspecified 0, Unknown HA 0
Administrative prohibited 0, No resource 0
Authentication failed MN 0, FA 0, active HA 0
Bad identification 0, Bad request form 0
Unavailable encap 0, reverse tunnel 0
Binding updates received 0, sent 0 total 0 fail 0
Binding update acks received 0, sent 0
Binding info request received 0, sent 0 total 0 fail 0
Binding info reply received 0 drop 0, sent 0 total 0 fail 0
Binding info reply acks received 0 drop 0, sent 0
Gratuitous 0, Proxy 0 ARPs sent
Foreign Agent Registrations:
Request in 0,
Forwarded 0, Denied 0, Ignored 0
Unspecified 0, HA unreachable 0
Administrative prohibited 0, No resource 0
Bad lifetime 0, Bad request form 0
Unavailable encapsulation 0, Compression 0
Unavailable reverse tunnel 0
Replies in 0
Forwarded 0, Bad 0, Ignored 0
Authentication failed MN 0, HA 0

MobileRtr#sh int tu 0
Tunnel0 is up, line protocol is up
Hardware is Tunnel
Interface is unnumbered. Using address of Ethernet1 (172.16.2.1)
MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive set (10 sec)
Tunnel source 172.16.2.1, destination 1.1.1.1
Tunnel protocol/transport IP/IP, key disabled, sequencing disabled
Checksumming of packets disabled, fast tunneling enabled
Path MTU Discovery, ager 10 mins, MTU 0, expires never
Last input 00:00:10, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
49 packets input, 4928 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out

Note all the traffic is coming IN through the tunnel, but not going OUT via the tunnel.

MobileRtr#sh ip mob bi
%HA is not enabled

MobileRtr#sh ip mob gl
IP Mobility global information:
Home Agent is not enabled

Foreign Agent is not enabled, no care-of address

0 interfaces providing service
Encapsulations supported: IPIP and GRE
Tunnel fast switching enabled
Tunnel path MTU discovery aged out after 10 min

MobileRtr#sh ip mob mob
%HA is not enabled

MobileRtr#sh ip mob secu ?
foreign-agent Foreign agent security associations
home-agent Home agent security associations
host Mobile host security associations
summary Summary of SAs
visitor Mobile visitor security associations

MobileRtr#sh ip mob secu summ
Security Associations (algorithm,mode,replay protection,key):
Total 1

MobileRtr#sh ip mob secu home
Security Associations (algorithm,mode,replay protection,key):
1.1.1.1:
SPI 100, MD5, Prefix-suffix, Timestamp +/- 7,
Key 'cisco'

MobileRtr#sh ip int brief
Interface     IP-Address     OK?     Method     Status     Protocol
Ethernet0     148.33.2.129   YES     NVRAM      up         up
Ethernet1     172.16.2.1     YES     NVRAM      up         up
Mobile0       unassigned     YES     unset      up         up
Serial0       unassigned     YES     NVRAM      administratively down down
Serial1       unassigned     YES     NVRAM      administratively down down
Tunnel0       172.16.2.1     YES     unset      up         up
 


ForeignAgent Show Commands

ForeignAgent#sh ip rou
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

D    1.0.0.0/8 [90/2297856] via 192.30.1.1, 01:40:49, Serial0
     2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       2.2.2.2/32 is directly connected, Loopback0
D       2.0.0.0/8 is a summary, 01:40:40, Null0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.16.0.0/16 [90/2195456] via 192.30.1.1, 01:40:49, Serial0
M       172.16.2.1/32 [3/1] via 172.16.2.1, 01:29:43, Ethernet0
C    192.30.1.0/24 is directly connected, Serial0
D EX 148.33.0.0/16 [170/257024000] via 192.30.1.1, 01:25:38, Serial0
C    192.30.2.0/24 is directly connected, Ethernet0
C    192.30.3.0/24 is directly connected, Ethernet1

ForeignAgent#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  172.16.2.1             78   0010.7b80.ef4d  ARPA   Ethernet0
Internet  172.16.2.1             77   0010.7b80.ef4d  ARPA   Ethernet1
Internet  192.30.3.1              -   0010.7b80.eadd  ARPA   Ethernet1
Internet  192.30.2.1              -   0010.7b80.eadc  ARPA   Ethernet0

ForeignAgent#trace 148.33.2.130

Type escape sequence to abort.
Tracing the route to 148.33.2.130

1 192.30.1.1 4 msec 4 msec 4 msec
2 172.16.2.1 4 msec 8 msec 8 msec
3 148.33.2.130 12 msec 8 msec 12 msec

Note that traffic going to the host behind the Mobile Router does get routed via the Home Agent.

ForeignAgent#sh ip mob vis
Mobile Visitor List:
Total 1
172.16.2.1:
    Interface Ethernet1, MAC addr 0010.7b80.ef4d
    IP src 172.16.2.1, dest 192.30.3.1, UDP src port 434
    HA addr 1.1.1.1, Identification AF3BDCE1.978CAC28
    Lifetime 10:00:00 (36000) Remaining 09:57:26
    Tunnel0 src 192.30.1.2, dest 1.1.1.1, reverse-allowed
    Routing Options -

ForeignAgent#sh ip mob secu vis
Security Associations (algorithm,mode,replay protection,key):

ForeignAgent#sh ip mob secu sum
Security Associations (algorithm,mode,replay protection,key):
Total 0

ForeignAgent#sh ip mob vis
Mobile Visitor List:
Total 1
172.16.2.1:
Interface Ethernet0, MAC addr 0010.7b80.ef4d
IP src 172.16.2.1, dest 192.30.2.1, UDP src port 434
HA addr 1.1.1.1, Identification AF3BDD95.DD2DA678
Lifetime 10:00:00 (36000) Remaining 09:59:55
Tunnel0 src 192.30.1.2, dest 1.1.1.1, reverse-allowed
Routing Options -

The above command is the one to watch if you're swapping interfaces, to make sure the Mobile Router does get picked up on the new interface.

ForeignAgent#sh ip mob bin
%HA is not enabled

ForeignAgent#sh ip mob gl
IP Mobility global information:
Home Agent is not enabled

Foreign Agent

Pending registrations expire after 15 secs
Care-of addresses advertised
Serial0 (192.30.1.2) - up

2 interfaces providing service
Encapsulations supported: IPIP and GRE
Tunnel fast switching enabled
Tunnel path MTU discovery aged out after 10 min

ForeignAgent#sh ip mob int
IP Mobility interface information:
Interface Ethernet0:
IRDP (includes agent advertisement) enabled
Prefix Length not advertised
Lifetime is 36000 seconds
Foreign Agent service provided
No registration required
Not busy
Home Agent access list:
Current number of visitors: 1
Interface Ethernet1:
IRDP (includes agent advertisement) enabled
Prefix Length not advertised
Lifetime is 36000 seconds
Foreign Agent service provided
No registration required
Not busy
Home Agent access list:
Current number of visitors: 0

ForeignAgent#sh ip mob traff
IP Mobility traffic:
Advertisements:
Solicitations received 1
Advertisements sent 604, response to solicitation 1
Home Agent Registrations:
Register 0, Deregister 0 requests
Register 0, Deregister 0 replied
Accepted 0, No simultaneous bindings 0
Denied 0, Ignored 0 , Dropped 0
Unspecified 0, Unknown HA 0
Administrative prohibited 0, No resource 0
Authentication failed MN 0, FA 0, active HA 0
Bad identification 0, Bad request form 0
Unavailable encap 0, reverse tunnel 0
Binding updates received 0, sent 0 total 0 fail 0
Binding update acks received 0, sent 0
Binding info request received 0, sent 0 total 0 fail 0
Binding info reply received 0 drop 0, sent 0 total 0 fail 0
Binding info reply acks received 0 drop 0, sent 0
Gratuitous 0, Proxy 0 ARPs sent
Foreign Agent Registrations:
Request in 8,
Forwarded 8, Denied 0, Ignored 0
Unspecified 0, HA unreachable 0
Administrative prohibited 0, No resource 0
Bad lifetime 0, Bad request form 0
Unavailable encapsulation 0, Compression 0
Unavailable reverse tunnel 0
Replies in 8
Forwarded 8, Bad 0, Ignored 0
Authentication failed MN 0, HA 0

ForeignAgent#sh ip mob tunn
Mobile Tunnels:

Tunnel0:
src 192.30.1.2, dest 1.1.1.1
encap IP/IP, mode reverse-allowed, tunnel-users 1
IP MTU 1480 bytes
Path MTU Discovery, mtu: 0, ager: 10 mins, expires: never
outbound interface Serial0
FA created, fast switching enabled, ICMP unreachable enabled
40522 packets input, 6715972 bytes, 0 drops
0 packets output, 0 bytes

ForeignAgent#sh int tu 0
Tunnel0 is up, line protocol is up
Hardware is Tunnel
Interface is unnumbered. Using address of Serial0 (192.30.1.2)
MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive not set
Tunnel source 192.30.1.2, destination 1.1.1.1
Tunnel protocol/transport IP/IP, key disabled, sequencing disabled
Checksumming of packets disabled, fast tunneling enabled
Path MTU Discovery, ager 10 mins, MTU 0, expires never
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
40522 packets input, 6715972 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out

I had HP OpenView running on the client PC, and it was going nuts trying to poll nodes from a previous test scenario (no longer present).  It turned out it was quietly putting out about 1000 packets / second when I was watching via this command. CPU load on the 2500 was still pretty minimal: 10-15%.

ForeignAgent#sh ip mob vis
Mobile Visitor List:
Total 1
172.16.2.1:
Interface Ethernet0, MAC addr 0010.7b80.ef4d
IP src 172.16.2.1, dest 192.30.2.1, UDP src port 434
HA addr 1.1.1.1, Identification AF3BDD95.DD2DA678
Lifetime 10:00:00 (36000) Remaining 09:59:08
Tunnel0 src 192.30.1.2, dest 1.1.1.1, reverse-allowed
Routing Options -

ForeignAgent#sh ip int brief
Interface     IP-Address     OK?     Method     Status     Protocol
Ethernet0     192.30.2.1     YES     manual     up         up
Ethernet1     192.30.3.1     YES     NVRAM      up         up
Loopback0     2.2.2.2        YES     manual     up         up
Mobile0       unassigned     YES     unset      up         up
Serial0       192.30.1.2     YES     NVRAM      up         up
Serial1       unassigned     YES     NVRAM      administratively down down
Tunnel0       192.30.1.2     YES     unset      up         up

The following is a sample of Extended PING, running while the Ethernet was swapped one way then back. The '....' characters indicate outages while this was going on. PING timeout was at the default two seconds, so four dots or eight seconds was about what I expected. The larger gap on swapping back was a bit unexpected, apparently about 26 seconds, perhaps requiring a timeout before acquiring the new foreign agent address.

ForeignAgent#ping
Protocol [ip]:
Target IP address: 148.33.2.130
Repeat count [5]: 1000
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 1000, 100-byte ICMP Echos to 148.33.2.130, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!..
..!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!...........
..!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!
Success rate is 98 percent (983/1000), round-trip min/avg/max = 8/10/56 ms


HomeAgent Show Commands

HomeAgent#sh ip rou
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter are
a
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 1.1.1.1/32 is directly connected, Loopback0
D 1.0.0.0/8 is a summary, 00:42:46, Null0
D 2.0.0.0/8 [90/2297856] via 192.30.1.2, 00:28:21, Serial0
172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks
D 172.16.0.0/16 is a summary, 00:55:48, Null0
M 172.16.2.0/24 is directly connected, Mobile0
M 172.16.2.1/32 [3/1] via 192.30.1.2, 00:21:04, Tunnel0
C 172.16.100.0/24 is directly connected, Ethernet0
C 192.30.1.0/24 is directly connected, Serial0
M 148.33.0.0/16 [3/1] via 172.16.2.1, 00:21:05, Tunnel1
D 192.30.2.0/24 [90/2195456] via 192.30.1.2, 00:52:42, Serial0
D 192.30.3.0/24 [90/2195456] via 192.30.1.2, 00:55:40, Serial0

Note the Mobile entries in the routing table!

HomeAgent#sh int tu 0
Tunnel0 is up, line protocol is up
Hardware is Tunnel
Interface is unnumbered. Using address of Loopback0 (1.1.1.1)
MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive not set
Tunnel source 1.1.1.1, destination 192.30.1.2
Tunnel protocol/transport IP/IP, key disabled, sequencing disabled
Checksumming of packets disabled, fast tunneling enabled
Path MTU Discovery, ager 10 mins, MTU 0, expires never
Last input never, output 00:12:47, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
40522 packets output, 7526412 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out

HomeAgent#sh ip int brie
Interface    IP-Address    OK?    Method    Status        Protocol
Ethernet0    172.16.100.1  YES    NVRAM     up            up
Ethernet1    unassigned    YES    NVRAM     administratively down down
Loopback0    1.1.1.1       YES    manual    up            up
Mobile0      unassigned    YES    unset     up            up
Serial0      192.30.1.1    YES    NVRAM     up            up
Serial1      unassigned    YES    NVRAM     administratively down down
Tunnel0      1.1.1.1       YES    unset     up            up
Tunnel1      1.1.1.1       YES    unset     up            up

HomeAgent#sh int tu 1
Tunnel1 is up, line protocol is up
Hardware is Tunnel
Interface is unnumbered. Using address of Loopback0 (1.1.1.1)
MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive not set
Tunnel source 1.1.1.1, destination 172.16.2.1
Tunnel protocol/transport IP/IP, key disabled, sequencing disabled
Checksumming of packets disabled, fast tunneling enabled
Path MTU Discovery, ager 10 mins, MTU 0, expires never
Last input never, output 00:13:11, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/0, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
40500 packets output, 6714040 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out

HomeAgent#sh ip mob bin
Mobility Binding List:
Total 1
172.16.2.1:
Care-of Addr 192.30.1.2, Src Addr 192.30.1.2
Lifetime granted 10:00:00 (36000), remaining 09:58:20
Flags sbdmgvt, Identification AF3BDD95.DD2DA678
Tunnel0 src 1.1.1.1 dest 192.30.1.2 reverse-allowed
MR Tunnel1 src 1.1.1.1 dest 172.16.2.1 reverse-allowed mobile-network 172.
16.2.1
Routing Options -

HomeAgent#sh ip mob gl
IP Mobility global information:

Home Agent

Registration lifetime: 10:00:00 (36000 secs)
Broadcast disabled
Replay protection time: 7 secs
Reverse tunnel enabled
ICMP Unreachable enabled
Virtual networks
172.16.2.0 /24

Foreign Agent is not enabled, no care-of address

0 interfaces providing service
Encapsulations supported: IPIP and GRE
Tunnel fast switching enabled
Tunnel path MTU discovery aged out after 10 min

HomeAgent#sh ip mob hos
Mobile Host List:

Total 1
172.16.2.1:
    Allowed lifetime 10:00:00 (36000/default)
    Roam status -Registered-, Home link on virtual network 172.16.2.0 /24
    Accepted 6, Last time 03/01/93 00:55:50
    Overall service time 00:21:44
    Denied 2, Last time 03/01/93 00:51:38
    Last code 'registration id mismatch (133)'
    Total violations 2
    Tunnel to MN - pkts 40522, bytes 6715972
    Reverse tunnel from MN - pkts 0, bytes 0
    Mobile networks (172.16.2.1)
        148.33.0.0 / 255.255.0.0

HomeAgent#sh ip mob int
IP Mobility interface information:

HomeAgent#sh ip mob mob
Mobile Networks
172.16.2.1 (MR 172.16.2.1):
148.33.0.0 / 255.255.0.0

HomeAgent#sh ip mob sec summ
Security Associations (algorithm,mode,replay protection,key):
Total 1

HomeAgent#sh ip mob sec hos
Security Associations (algorithm,mode,replay protection,key):
172.16.2.1:
SPI 100, MD5, Prefix-suffix, Timestamp +/- 7,
Key 'cisco'

HomeAgent#sh ip mob traff
IP Mobility traffic:
Advertisements:
Solicitations received 0
Advertisements sent 0, response to solicitation 0
Home Agent Registrations:
Register 8, Deregister 0 requests
Register 8, Deregister 0 replied
Accepted 6, No simultaneous bindings 0
Denied 2, Ignored 0 , Dropped 0
Unspecified 0, Unknown HA 0
Administrative prohibited 0, No resource 0
Authentication failed MN 0, FA 0, active HA 0
Bad identification 2, Bad request form 0
Unavailable encap 0, reverse tunnel 0
Binding updates received 0, sent 0 total 0 fail 0
Binding update acks received 0, sent 0
Binding info request received 0, sent 0 total 0 fail 0
Binding info reply received 0 drop 0, sent 0 total 0 fail 0
Binding info reply acks received 0 drop 0, sent 0
Gratuitous 0, Proxy 0 ARPs sent
Foreign Agent Registrations:
Request in 0,
Forwarded 0, Denied 0, Ignored 0
Unspecified 0, HA unreachable 0
Administrative prohibited 0, No resource 0
Bad lifetime 0, Bad request form 0
Unavailable encapsulation 0, Compression 0
Unavailable reverse tunnel 0
Replies in 0
Forwarded 0, Bad 0, Ignored 0
Authentication failed MN 0, HA 0

HomeAgent#sh ip mob tunn
Mobile Tunnels:

Tunnel1:
src 1.1.1.1, dest 172.16.2.1
encap IP/IP, mode reverse-allowed, tunnel-users 1
IP MTU 1460 bytes
Path MTU Discovery, mtu: 0, ager: 10 mins, expires: never
outbound interface Tunnel0
HA created, fast switching enabled, ICMP unreachable enabled
0 packets input, 0 bytes, 0 drops
40500 packets output, 6714040 bytes
Tunnel0:
src 1.1.1.1, dest 192.30.1.2
encap IP/IP, mode reverse-allowed, tunnel-users 1
IP MTU 1480 bytes
Path MTU Discovery, mtu: 0, ager: 10 mins, expires: never
outbound interface Serial0
HA created, fast switching enabled, ICMP unreachable enabled
0 packets input, 0 bytes, 0 drops
40522 packets output, 7526412 bytes

HomeAgent#sh ip mob vio
Security Violation Log:

Total violations 2
Mobile Hosts:
172.16.2.1:
Violations: 2, Last time: 03/01/93 00:51:38
SPI: 100, Identification: AF3BD0CB.936FACC
Error Code: registration id mismatch (133), Reason: Bad identifier (3)

HomeAgent#sh ip mob vis
%FA is not enabled


Dr. Peter J. Welcher (CCIE #1773, CCSI #94014) is a Senior Consultant with Chesapeake NetCraftsmen. NetCraftsmen is a high-end consulting firm and Cisco Premier Partner dedicated to quality consulting and knowledge transfer. NetCraftsmen has eleven CCIE's (4 of whom are double-CCIE's, R&S and Security). NetCraftsmen has expertise including large network high-availability routing/switching and design, VoIP, QoS, MPLS, network management, security, IP multicast, and other areas. See http://www.netcraftsmen.net for more information about NetCraftsmen. . New articles will be posted under the Articles link. Questions, suggestions for articles, etc. can be sent to This email address is being protected from spambots. You need JavaScript enabled to view it. .

12/28/2001
Copyright (C)  2001,  Peter J. Welcher